summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2023-07-18 13:10:51 +0200
committerLudovic Courtès <ludo@gnu.org>2023-07-18 14:06:49 +0200
commit08870dc3bc2a82e8df0b9fb1487bef5769127648 (patch)
treeefefa21cdee8f6f03d871b2aa1fa4358022defdc
parent3a3752400d7a70a295a27b66f29457aeeaa2cf27 (diff)
downloadguix-08870dc3bc2a82e8df0b9fb1487bef5769127648.tar.gz
gnu: insight-toolkit: Fix compilation.
Previously, code would be compiled with '-std=c++11', leading to
compilation errors in VNL:

  vnl_bignum.cxx:738:37: error: ‘numeric_limits’ is not a member of ‘std’

* gnu/packages/image-processing.scm (insight-toolkit)[arguments]: Pass
"-DCMAKE_CXX_STANDARD=17".
-rw-r--r--gnu/packages/image-processing.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 3a846cbe25..d8a20c08aa 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -1288,7 +1288,8 @@ libraries designed for computer vision research and implementation.")
          ;; This prevents "GTest::GTest" from being added to the ITK_LIBRARIES
          ;; variable in the installed CMake files.  This is necessary as other
          ;; packages using insight-toolkit could not be configured otherwise.
-         "-DGTEST_ROOT=gtest")
+         "-DGTEST_ROOT=gtest"
+         "-DCMAKE_CXX_STANDARD=17")
 
        #:phases
        (modify-phases %standard-phases