summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-13 11:58:08 +0200
committerMarius Bakke <marius@gnu.org>2022-08-13 19:09:14 +0200
commit27555b05661931f7087b735db7be715ab9ac8f27 (patch)
tree22727525ab014b59dad8c0cda06d6ee0513657c0
parent00e78042b7e1e740bacb42008781548cf763d167 (diff)
downloadguix-27555b05661931f7087b735db7be715ab9ac8f27.tar.gz
gnu: python-sphinx-panels: Use python-sphinx@4.
...also add deprecation notice, and change its users accordingly.

* gnu/packages/sphinx.scm (python-sphinx-panels)[propagated-inputs]: Change
from PYTHON-SPHINX to PYTHON-SPHINX-4.
[description]: Mention that it is unmaintained.
* gnu/packages/python-science.scm (python-scipy)[native-inputs]: Likewise.
* gnu/packages/python-xyz.scm (python-numpy-documentation)[native-inputs]: Likewise.
-rw-r--r--gnu/packages/python-science.scm2
-rw-r--r--gnu/packages/python-xyz.scm2
-rw-r--r--gnu/packages/sphinx.scm6
3 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 95f60aae7b..ce0ba4b6d2 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -146,7 +146,7 @@ atlas_libs = openblas~%"  #$(this-package-input "openblas"))))))
            python-pydata-sphinx-theme
            python-pytest
            python-pytest-xdist
-           python-sphinx
+           python-sphinx-4
            python-sphinx-panels
            python-threadpoolctl
            which))
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e76d944025..85f8c3c00b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5731,7 +5731,7 @@ capabilities.")
            python-pandas
            python-pydata-sphinx-theme
            python-scipy                 ;used by matplotlib
-           python-sphinx
+           python-sphinx-4
            python-sphinx-panels
            texinfo
            texlive-bin
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 036950e8cf..1e628a0e75 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -377,14 +377,16 @@ Blog, News or Announcements section to a Sphinx website.")
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
                (invoke "pytest")))))))
-    (propagated-inputs (list python-docutils python-sphinx))
+    (propagated-inputs (list python-docutils python-sphinx-4))
     (native-inputs
      (list python-pytest
            python-pytest-regressions))
     (home-page "https://github.com/executablebooks/sphinx-panels")
     (synopsis "Sphinx extension for creating panels in a grid layout")
     (description
-     "This package provides a sphinx extension for creating panels in a grid layout.")
+     "This package provides a sphinx extension for creating panels in a
+grid layout.  It is no longer maintained and users are encouraged to use
+@code{sphinx-design} instead.")
     (license license:expat)))
 
 (define-public python-sphinxcontrib-programoutput