summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-08-14 16:08:17 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-14 16:08:17 +0200
commit2759d4ca74ff4846b79c406c000b64dc2f2ed0ac (patch)
tree166f995b4f2467dcd47f8255f13db7dae2e72958
parent4ca80a2b95bdcc4034c4189b8d43a63d094ef3bd (diff)
downloadguix-2759d4ca74ff4846b79c406c000b64dc2f2ed0ac.tar.gz
gnu: opencv: Fix build with new version of jasper.
* gnu/packages/image-processing.scm (opencv): Fix build failure.
[arguments]<#:phases>[fix-jasper]: New phase.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/image-processing.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 52e0311943..b93ad161db 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -358,6 +358,14 @@ integrates with various databases on GUI toolkits such as Qt and Tk.")
                      "--strip-components=1"
                      "-C" "../opencv-contrib")))
 
+         (add-after 'unpack 'fix-jasper
+           (lambda _
+             ;; See <https://github.com/opencv/opencv/pull/17983>.
+             (substitute* "modules/imgcodecs/src/grfmt_jpeg2000.cpp"
+               (("&jas_matrix_get")
+                "jas_matrix_getref"))
+             #t))
+
          (add-after 'set-paths 'add-ilmbase-include-path
            (lambda* (#:key inputs #:allow-other-keys)
            ;; OpenEXR propagates ilmbase, but its include files do not appear