summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-09-28 11:25:38 +0200
committerLudovic Courtès <ludo@gnu.org>2023-09-28 11:44:08 +0200
commit51e1df07b1d21840551eb8dc15b4bfe5612e1bf9 (patch)
tree777f99bbe9bf5dc5ae0b082b322493e0e0fc951d
parente67cb380f78af1be21e550b42e88ee28e524d886 (diff)
downloadguix-51e1df07b1d21840551eb8dc15b4bfe5612e1bf9.tar.gz
gnu: openssl@1.1: Upgrade replacement to 1.1.1u.
Includes fixes for CVE-2023-0215, CVE-2023-0286, CVE-2023-0464, CVE-2023-0465,
CVE-2023-0466, CVE-2023-2650, CVE-2022-4304, CVE-2022-4450.

* gnu/packages/tls.scm (openssl/fixed): Update to 1.1.1u.

Co-authored-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
-rw-r--r--gnu/packages/tls.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index a9b70101c2..61484bfd86 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -553,7 +553,7 @@ OpenSSL for TARGET."
   (package
     (inherit openssl-1.1)
     (name "openssl")
-    (version "1.1.1t")
+    (version "1.1.1u")
     (source (origin
               (method url-fetch)
               (uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -566,7 +566,7 @@ OpenSSL for TARGET."
               (patches (search-patches "openssl-1.1-c-rehash-in.patch"))
               (sha256
                (base32
-                "0fwxhlv7ary9nzg5mx07x1jj3wkbizxh56qy7l6bzp5iplj9pvld"))))))
+                "1ipbcdlqyxbj5lagasrq2p6gn0036wq6hqp7gdnd1v1ya95xiy72"))))))
 
 (define-public openssl-3.0
   (package