summary refs log tree commit diff
diff options
context:
space:
mode:
authorKaelyn Takata <kaelyn.alexi@protonmail.com>2022-07-18 18:52:19 +0000
committerLudovic Courtès <ludo@gnu.org>2022-08-03 17:43:28 +0200
commit5791736e5ee194deb9d241cb47feb1cef80da525 (patch)
treee8d87828387ae9075e296f8540a39c375df2e3e9
parentb3f1666dd61df4cbb07d0e3d7ae0876d49ddf916 (diff)
downloadguix-5791736e5ee194deb9d241cb47feb1cef80da525.tar.gz
gnu: mingw: Update to 10.0.0.
* gnu/packages/mingw.scm (mingw): Update to 10.0.0.
[arguments] Disable parallel building to avoid failures trying to access empty
.a files.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/mingw.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/mingw.scm b/gnu/packages/mingw.scm
index 87a565059e..161fd4ff93 100644
--- a/gnu/packages/mingw.scm
+++ b/gnu/packages/mingw.scm
@@ -46,7 +46,7 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
     (package
       (name (string-append "mingw-w64" "-" machine
                            (if with-winpthreads? "-winpthreads" "")))
-      (version "8.0.0")
+      (version "10.0.0")
       (source
        (origin
          (method url-fetch)
@@ -54,7 +54,7 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
                "mirror://sourceforge/mingw-w64/mingw-w64/"
                "mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
          (sha256
-          (base32 "0qjpb9rviasfshk337j5r32ncmrwml8sv6qnmb1lp4mkdbm41is4"))
+          (base32 "15089y4rlj6g1m2m3cm3awndw3rbzhznl7skd0vkmikjxl546sxs"))
          (patches
           (search-patches "mingw-w64-6.0.0-gcc.patch"
                           "mingw-w64-dlltool-temp-prefix.patch"
@@ -108,6 +108,7 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
                               xlibc "/lib" ":"
                               xlibc "/" ,triplet "/lib"))))))))
          #:make-flags (list "DEFS=-DHAVE_CONFIG_H -D__MINGW_HAS_DXSDK=1")
+         #:parallel-build? #f ; parallel builds often fail with empty .a files
          #:tests? #f ; compiles and includes glibc headers
          #:strip-binaries? #f))
       (home-page "https://mingw-w64.org")