summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-03-20 09:48:34 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-03-20 11:19:29 +0100
commitcaf3209a8fbe83bd1953d7d3e3b6bfe0277ed493 (patch)
tree14121420edca8944074abe3bc233a6b75e80d84b
parent05d261b88e6fb86abeaa321a7ce44d9f7798cbd5 (diff)
downloadguix-caf3209a8fbe83bd1953d7d3e3b6bfe0277ed493.tar.gz
gnu: Add go-go-uber-org-zap.
* gnu/packages/golang.scm (go-go-uber-org-zap): New variable.
-rw-r--r--gnu/packages/golang.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1ad1e149a7..d9988cd7ad 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7001,3 +7001,36 @@ tools with similar semantics.")
 Using static analysis, it finds bugs and performance issues, offers
 simplifications, and enforces style rules.")
     (license license:expat)))
+
+(define-public go-go-uber-org-zap
+  (package
+    (name "go-go-uber-org-zap")
+    (version "1.16.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/uber-go/zap")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "05ix5wg1r8pgi7fb6084lg4x7mrkvzkh1nxa7zj337w5b9xj0myr"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "go.uber.org/zap"
+       #:tests? #f)) ; TODO: Fix tests
+    (native-inputs
+     `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
+       ("go-golang-org-x-lint" ,go-golang-org-x-lint)
+       ("go-honnef-co-go-tools" ,go-honnef-co-go-tools)))
+    (propagated-inputs
+     `(("go-github-com-pkg-errors" ,go-github-com-pkg-errors)
+       ("go-go-uber-org-atomic" ,go-go-uber-org-atomic)
+       ("go-go-uber-org-multierr" ,go-go-uber-org-multierr)
+       ("go-gopkg-in-yaml-v2" ,go-gopkg-in-yaml-v2)))
+    (home-page "https://go.uber.org/zap")
+    (synopsis "Logging library for Go")
+    (description
+     "This package provides a library for fast, structured, leveled logging in
+Go.")
+    (license license:expat)))