about summary refs log tree commit diff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix17
1 files changed, 13 insertions, 4 deletions
diff --git a/configuration.nix b/configuration.nix
index e94e52c..46bebac 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -41,10 +41,19 @@
   services = {
     nginx = {
       enable = true;
-      virtualHosts."loang.net" = {
-        enableACME = true;
-        forceSSL = true;
-        root = "/var/www/loang.net";
+      virtualHosts = let
+        users = config.users.users;
+      in {
+        "loang.net" = {
+          enableACME = true;
+          forceSSL = true;
+          root = "/var/www/loang.net";
+        };
+        "cnx.loang.net" = {
+          enableACME = true;
+          forceSSL = true;
+          root = "${users.cnx.home}/web";
+        };
       };
     };