about summary refs log tree commit diff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix15
1 files changed, 6 insertions, 9 deletions
diff --git a/configuration.nix b/configuration.nix
index 9bdcf54..340eab4 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -20,7 +20,7 @@
 {
   environment = {
     enableAllTerminfo = true;
-    systemPackages = with pkgs; [ git guix htop man-pages rsync vim ];
+    systemPackages = with pkgs; [ git htop man-pages rsync vim ];
   };
 
   fileSystems."/mnt/nas" = {
@@ -91,14 +91,11 @@
     wheelNeedsPassword = false;
   };
 
-  services = {
-    guix.enable = true;
-    openssh = {
-      enable = true;
-      openFirewall = true;
-      settings.PasswordAuthentication = false;
-      ports = [ 2211 ];
-    };
+  services.openssh = {
+    enable = true;
+    openFirewall = true;
+    settings.PasswordAuthentication = false;
+    ports = [ 2211 ];
   };
 
   system.stateVersion = "22.05";