about summary refs log tree commit diff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix18
1 files changed, 6 insertions, 12 deletions
diff --git a/configuration.nix b/configuration.nix
index 9e00c0a..fe0ab32 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -28,18 +28,11 @@ in {
   networking = {
     domain = "loang.net";
 
-    firewall = {
-      allowedTCPPorts = [
-        80 # HTTP
-        443 # TLS
-        1965 # Gemini
-        2211 # SSH
-        4001 # IPFS
-      ];
-      allowedUDPPorts = [
-        4001 # IPFS
-      ];
-    };
+    firewall.allowedTCPPorts = [
+      80 # HTTP
+      443 # TLS
+      1965 # Gemini
+    ];
 
     hostName = "brno";
   };
@@ -78,6 +71,7 @@ in {
 
     openssh = {
       enable = true;
+      openFirewall = true;
       passwordAuthentication = false;
       ports = [ 2211 ];
     };