about summary refs log tree commit diff
path: root/mail.nix
diff options
context:
space:
mode:
Diffstat (limited to 'mail.nix')
-rw-r--r--mail.nix16
1 files changed, 6 insertions, 10 deletions
diff --git a/mail.nix b/mail.nix
index 1fd2d01..61b80c1 100644
--- a/mail.nix
+++ b/mail.nix
@@ -76,16 +76,12 @@ in {
       "mta-sts.${domain}" = {
         enableACME = true;
         forceSSL = true;
-        locations."/".root = pkgs.writeTextFile {
-          name = "mta-sts.txt";
-          text = ''
-            version: STSv1
-            mode: enforce
-            max_age: 604800
-            mx: ${hostname}
-          '';
-          destination = "/.well-known/mta-sts.txt";
-        };
+        locations."/".root = pkgs.writeTextDir ".well-known/mta-sts.txt" ''
+          version: STSv1
+          mode: enforce
+          max_age: 604800
+          mx: ${hostname}
+        '';
       };
 
       ${domain}.locations."^~ /.well-known/openpgpkey" = {