about summary refs log tree commit diff
path: root/nix/devel.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/devel.nix')
-rw-r--r--nix/devel.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/nix/devel.nix b/nix/devel.nix
index c6656ad..b7321a9 100644
--- a/nix/devel.nix
+++ b/nix/devel.nix
@@ -5,7 +5,7 @@
     exa fd gitAndTools.gitFull glow jq kvm minicom manpages ripgrep rlwrap
     gcc lua python3 rakudo zig
     bintools gdb gnumake luaPackages.luacheck mypy pkg-config
-    plantuml sile texlive.combined.scheme-full
+    plantuml texlive.combined.scheme-full
   ] ++ (with python3Packages; [ flit pip tox ]);
 
   programs.mtr.enable = true;
@@ -15,7 +15,12 @@
   };
 
   services = {
-    # openssh.enable = true;
+    openssh = {
+      enable = true;
+      passwordAuthentication = false;
+      kbdInteractiveAuthentication = false;
+    };
+
     ipfs = {
       enable = true;
       user = "sea";