about summary refs log tree commit diff
path: root/nix/etc/nixos/awesome.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/etc/nixos/awesome.nix')
-rw-r--r--nix/etc/nixos/awesome.nix40
1 files changed, 0 insertions, 40 deletions
diff --git a/nix/etc/nixos/awesome.nix b/nix/etc/nixos/awesome.nix
deleted file mode 100644
index dfd526d..0000000
--- a/nix/etc/nixos/awesome.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-{ pkgs, ... }:
-
-{
-  imports = [ ./redshift.nix ];
-
-  fonts.fonts = with pkgs; [ lmodern ];
-
-  services = {
-    autorandr.enable = true;
-    xserver = {
-      enable = true;
-      displayManager.startx.enable = true;
-      windowManager.awesome.enable = true;
-
-      layout = "us";
-      xkbOptions = "caps:ctrl_modifier,compose:menu";
-      libinput.enable = true; # Enable touchpad support.
-    };
-  };
-
-  i18n = {
-    defaultLocale = "en_US.UTF-8";
-    inputMethod = {
-      enabled = "ibus";
-      ibus.engines = with pkgs.ibus-engines; [ table table-others ];
-    };
-  };
-
-  environment.systemPackages = with pkgs; [
-    gnome.adwaita-icon-theme qt5ct
-    gnome.networkmanagerapplet keynav mate.mate-power-manager
-    clipnotify playerctl pulsemixer xclip xdotool
-    rxvt_unicode-with-plugins urxvt_autocomplete_all_the_things urxvt_font_size
-    aerc amfora newsboat ranger ueberzug vim_configurable
-    arandr audacious firefox gimp nheko scrot xorg.xkill zathura
-  ];
-
-  programs.nm-applet.enable = true;
-  programs.slock.enable = true;
-}