summary refs log tree commit diff
path: root/.dir-locals.el
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-01 00:50:01 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-01 00:52:44 +0100
commit073c34d72f94adf6c4c307239b1de0d14bdb60f3 (patch)
treeb671d6032f3feb08513d80c1be4870053b5af671 /.dir-locals.el
parent111111d04662bb9056c8b56d11e634dc4506ee1e (diff)
downloadguix-073c34d72f94adf6c4c307239b1de0d14bdb60f3.tar.gz
Add (guix ui).
* guix/ui.scm: New file.
* Makefile.am (MODULES): Add it.
* po/POTFILES.in: Add it.

* guix-build.in: Use it.
  (_, N_, leave): Remove.
  (guix-build): Use `with-error-handling' instead of the `guard' form.
* guix-download.in: Use it.
  (_, N_, leave): Remove.
Diffstat (limited to '.dir-locals.el')
-rw-r--r--.dir-locals.el3
1 files changed, 2 insertions, 1 deletions
diff --git a/.dir-locals.el b/.dir-locals.el
index f04fdc6fc7..cbf60b5da1 100644
--- a/.dir-locals.el
+++ b/.dir-locals.el
@@ -10,7 +10,8 @@
    (eval . (put 'substitute* 'scheme-indent-function 1))
    (eval . (put 'with-directory-excursion 'scheme-indent-function 1))
    (eval . (put 'package 'scheme-indent-function 1))
-   (eval . (put 'substitute-keyword-arguments 'scheme-indent-function 1))))
+   (eval . (put 'substitute-keyword-arguments 'scheme-indent-function 1))
+   (eval . (put 'with-error-handling 'scheme-indent-function 0))))
  (emacs-lisp-mode . ((indent-tabs-mode . nil)))
  (texinfo-mode    . ((indent-tabs-mode . nil)
                      (fill-column . 72))))