summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-25 00:49:01 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-25 02:01:34 -0400
commit03c2af6295babf0d7b74c7f7c8df537dbe324214 (patch)
tree1d80fbb14f5eb29380e4a40c4ff31def642e746a
parentbb32e349e12c9281a61cc669a7ae5ed6fb524a66 (diff)
downloadguix-03c2af6295babf0d7b74c7f7c8df537dbe324214.tar.gz
gnu: Add python-patch-ng.
* gnu/packages/python-xyz.scm (python-patch-ng): New variable.
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ef44b00836..d9d1c8eb35 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5695,6 +5695,38 @@ flexible plugin systems in Python.")
 semantic version parser for Node.js.")
     (license license:expat)))
 
+(define-public python-patch-ng
+  (package
+    (name "python-patch-ng")
+    (version "1.17.4")
+    (source
+     (origin
+       (method git-fetch)               ;no tests in PyPI archive
+       (uri (git-reference
+             (url "https://github.com/conan-io/python-patch-ng")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0qxn4ss2s54qy87xrpcybz26kp2fwlaq41x4k9jcmp6d7p0w569m"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (when tests?
+                        (invoke "tests/run_tests.py" "-v")))))))
+    (home-page "https://github.com/conan-io/python-patch-ng")
+    (synopsis "Python library to parse and apply unified diffs")
+    (description "Patch NG (New Generation) is a command and Python library to
+parse and apply unified diffs.  It has features such as:
+@itemize
+@item automatic correction of common patch formatting corruption
+@item patch format detection (SVN, Hg, Git)
+@item nice diffstat histogram.
+@end itemize")
+    (license license:expat)))
+
 (define-public python-pyparsing
   (package
     (name "python-pyparsing")