summary refs log tree commit diff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-09-19 23:56:14 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-10-12 11:41:58 +0530
commit0d659f8211703a4bdfdd11d9cb36afb563da855b (patch)
treea819f88ad57c071e47d292d54ef44b588fa11995
parent4c08fef860132b5caeca51204f298db023e90dca (diff)
downloadguix-0d659f8211703a4bdfdd11d9cb36afb563da855b.tar.gz
gnu: Add rust-tower-service-0.3.
* gnu/packages/crates-io.scm (rust-tower-service-0.3): New variable.
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3206689e4d..425eed62c8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -27886,6 +27886,29 @@ serializing Rust structures.")
         ("rust-serde" ,rust-serde-0.8))))
     (home-page "https://github.com/alexcrichton/toml-rs")
     (synopsis "Rust encoder and decoder of TOML-formatted files and streams")
+
+(define-public rust-tower-service-0.3
+  (package
+    (name "rust-tower-service")
+    (version "0.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "tower-service" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0q4q53w82w1wd71x7vbspg2l3jicb6al2w1qdwxmnjrz8jzvd1z9"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-development-inputs
+       (("rust-http" ,rust-http-0.1))))
+    (home-page "https://github.com/tower-rs/tower")
+    (synopsis "Asynchronous, request / response based, client or server.")
+    (description "This package provides a trait representing an asynchronous,
+request/response based, client or server.")
+    (license license:expat)))
+
     (description
      "This package provides a native Rust encoder and decoder of TOML-formatted
 files and streams.  Provides implementations of the standard