summary refs log tree commit diff
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2021-08-06 00:38:31 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-06 00:39:51 -0400
commit0d72f24ac084acf9d69e147a692e5d8bcb2ea21b (patch)
tree7ef1ec8e7ebcf27f8e838ef77f8a508aa29d89ce
parentc64c49b152b7713a5e09ae0cfdc1de86fb215966 (diff)
downloadguix-0d72f24ac084acf9d69e147a692e5d8bcb2ea21b.tar.gz
gnu: emacs-direnv: Patch the reference to direnv.
* gnu/packages/emacs-xyz.scm (emacs-direnv)
[phases]{patch-in-direnv}: New phase.

Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9cbd99b7b1..c7730caf10 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -210,6 +210,7 @@
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages shells)
+  #:use-module (gnu packages shellutils)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gnupg)
@@ -2888,6 +2889,18 @@ overlay below or above the point.  Corfu can be considered the minimalistic
        (sha256
         (base32 "0xkqn4604k2imas6azy1www56br8ls4iv9a44pxcd8h94j1fp44d"))))
     (build-system emacs-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-in-direnv
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let* ((direnv-path (assoc-ref inputs "direnv"))
+                    (direnv-bin (string-append
+                                 "\"" direnv-path "/bin/direnv\"")))
+               (substitute* "direnv.el"
+                 (("\"direnv\"") direnv-bin))))))))
+    (inputs
+     `(("direnv" ,direnv)))
     (propagated-inputs
      `(("dash" ,emacs-dash)
        ("with-editor" ,emacs-with-editor)))