summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:31 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:30 +0200
commit17ecd488266feb876fe7d444d5d195988f8aa242 (patch)
tree5b70e4d495a7304bca559776b3e638e236ed430b
parenta7ce1ce19c1ec9734bd47dbccf87d5ffc8a8966d (diff)
downloadguix-17ecd488266feb876fe7d444d5d195988f8aa242.tar.gz
gnu: Add trytond-production-work-timesheet.
* gnu/packages/tryton.scm (trytond-production-work-timesheet): New variable.
-rw-r--r--gnu/packages/tryton.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 346d354b38..35388eda8f 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2526,6 +2526,31 @@ work order for each production.  It also adds in the production cost for the
 work cost.")
     (license license:gpl3+)))
 
+(define-public trytond-production-work-timesheet
+  (package
+    (name "trytond-production-work-timesheet")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_production_work_timesheet" version))
+       (sha256
+        (base32 "1r7k25wddd381g0p5pj3m8jqvbg8g6ss0ifnhhjya3b6x0d41jz9"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "production_work_timesheet"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-production-routing" ,trytond-production-routing)
+       ("trytond-production-work" ,trytond-production-work)
+       ("trytond-timesheet" ,trytond-timesheet)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-production-work-timesheet")
+    (synopsis "Tryton module for timesheet on production work")
+    (description "The @emph{Production Work Timesheet} Tryton module allows to
+enter timesheet for production works.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")