summary refs log tree commit diff
diff options
context:
space:
mode:
authorfesoj000 <fesoj000@gmail.com>2022-03-27 00:34:29 +0100
committerLudovic Courtès <ludo@gnu.org>2022-04-11 13:51:07 +0200
commit2a1908b48cdd127988083d3a5fb939e679bc3d17 (patch)
treede12185d72b2caab579513dd9b5d57c8866c6c5c
parenteb1d2ae7e028910a5fcf936d909c9c2dad01fe1a (diff)
downloadguix-2a1908b48cdd127988083d3a5fb939e679bc3d17.tar.gz
gnu: Add libnetfilter-log
* gnu/packages/linux.scm (libnetfilter-log): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/linux.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d9e04f22d3..6d699e0528 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7507,6 +7507,36 @@ deleting objects from the nfacct table
     (supported-systems (filter target-linux? %supported-systems))
     (license license:gpl2+)))
 
+(define-public libnetfilter-log
+  (package
+    (name "libnetfilter-log")
+    (version "1.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://netfilter.org/projects/"
+                           "libnetfilter_log/files/"
+                           "libnetfilter_log-" version ".tar.bz2"))
+       (sha256
+        (base32
+         "1spy9xs41v76kid5ana8n126f3mvgq6fjibbfbj4kn0larbhix73"))))
+    (build-system gnu-build-system)
+    (native-inputs (list pkg-config))
+    (inputs (list libnfnetlink libmnl))
+    (synopsis "Library providing interface to packets logged by netfilter")
+    (description "libnetfilter_log is a userspace library providing interface to
+packets that have been logged by the kernel packet filter.  It is is part of a
+system that deprecates the old syslog/dmesg based packet logging.  This library
+has been previously known as libnfnetlink_log.
+
+@enumerate
+@item
+receiving to-be-logged packets from the kernel nfnetlink_log subsystem
+@end enumerate")
+    (home-page "https://netfilter.org/projects/libnetfilter_log/index.html")
+    (supported-systems (filter target-linux? %supported-systems))
+    (license license:gpl2+)))
+
 (define-public proot
   (package
     (name "proot")