summary refs log tree commit diff
diff options
context:
space:
mode:
authorSarah Morgensen <iskarian@mgsn.dev>2021-09-19 11:46:52 -0700
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:31 -0500
commit460d6aca0c9a8f8443d50e5a5cf2bf9841bcc559 (patch)
tree513219c39a206bad39aa043df89b46679fb72251
parent3dfe45c3f10e31a016b22127eede8099ca4f4b8f (diff)
downloadguix-460d6aca0c9a8f8443d50e5a5cf2bf9841bcc559.tar.gz
gnu: curl: Honor #:tests?.
* gnu/packages/curl.scm (curl)[phases]{check}: Honor #:tests?.
-rw-r--r--gnu/packages/curl.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 063a919700..4c90c7b301 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -124,16 +124,16 @@
              (rename-file (string-append out "/share/man/man3")
                           (string-append doc "/share/man/man3"))
              #t)))
-        (replace
-         'check
-         (lambda _
-           (substitute* "tests/runtests.pl"
-             (("/bin/sh") (which "sh")))
+        (replace 'check
+          (lambda* (#:key tests? #:allow-other-keys)
+            (substitute* "tests/runtests.pl"
+              (("/bin/sh") (which "sh")))
 
-           ;; The top-level "make check" does "make -C tests quiet-test", which
-           ;; is too quiet.  Use the "test" target instead, which is more
-           ;; verbose.
-           (invoke "make" "-C" "tests" "test"))))))
+            (when tests?
+              ;; The top-level "make check" does "make -C tests quiet-test", which
+              ;; is too quiet.  Use the "test" target instead, which is more
+              ;; verbose.
+              (invoke "make" "-C" "tests" "test")))))))
    (synopsis "Command line tool for transferring data with URL syntax")
    (description
     "curl is a command line tool for transferring data with URL syntax,