summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-29 15:28:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-30 12:39:34 +0200
commit506436fde86aaa2f59c08f3f9178c7999eb2ba18 (patch)
tree3585e32563f7b0cef127d9501169d28b74774632
parent7aed4f72b000f5c8fe327519c3d82d52ebe139e8 (diff)
downloadguix-506436fde86aaa2f59c08f3f9178c7999eb2ba18.tar.gz
gnu: Add r-paws-developer-tools.
* gnu/packages/cran.scm (r-paws-developer-tools): New variable.
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6a059993ec..5b7b6da55b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31238,6 +31238,28 @@ management services, including cost and usage reports, budgets, pricing, and
 more.")
     (license license:asl2.0)))
 
+(define-public r-paws-developer-tools
+  (package
+    (name "r-paws-developer-tools")
+    (version "0.1.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "paws.developer.tools" version))
+       (sha256
+        (base32 "16gb8g8s67al7qdd95fbigxqkih9a9p7slkyf3cga42wb6miiby2"))))
+    (properties `((upstream-name . "paws.developer.tools")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-paws-common" ,r-paws-common)))
+    (home-page "https://github.com/paws-r/paws")
+    (synopsis "Amazon Web Services developer tools services")
+    (description
+     "This package provides an interface to Amazon Web Services developer
+tools services, including version control, continuous integration and
+deployment, and more.")
+    (license license:asl2.0)))
+
 (define-public r-paws-application-integration
   (package
     (name "r-paws-application-integration")