summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:31 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:30 +0200
commit650ba66b53d3f4d48fb56218d2628f41a44f0aa8 (patch)
tree8c24d23a58ad09380a245d41965a618fa6bf5f93
parent17ecd488266feb876fe7d444d5d195988f8aa242 (diff)
downloadguix-650ba66b53d3f4d48fb56218d2628f41a44f0aa8.tar.gz
gnu: Add trytond-project.
* gnu/packages/tryton.scm (trytond-project): New variable.
-rw-r--r--gnu/packages/tryton.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 35388eda8f..18f9a7393a 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2551,6 +2551,31 @@ work cost.")
 enter timesheet for production works.")
     (license license:gpl3+)))
 
+(define-public trytond-project
+  (package
+    (name "trytond-project")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_project" version))
+       (sha256
+        (base32 "1xlqzg07csr9a89jjgmk5n4d9dd2s3qahg2x8arf3vqqnrqw1g0f"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "project"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-company" ,trytond-company)
+       ("trytond-company-work-time" ,trytond-company-work-time)
+       ("trytond-party" ,trytond-party)
+       ("trytond-timesheet" ,trytond-timesheet)))
+    (home-page "https://docs.tryton.org/projects/modules-project")
+    (synopsis "Tryton module with projects")
+    (description "The @emph{Project} Tryton module provides the concepts of
+project and task and the basis for simple project management.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")