summary refs log tree commit diff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-12-05 12:18:24 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-05 12:18:24 +0100
commit66a2d3830cb6f8cd911dc3847b9ca82b5fddf62e (patch)
tree78fec54dc9b25f28de74916211850c91f8dc5af5
parent53afb3cf2adc9d83b03f5be834ca99e5f0db9d5b (diff)
downloadguix-66a2d3830cb6f8cd911dc3847b9ca82b5fddf62e.tar.gz
gnu: Add pudb.
* gnu/packages/python-xyz.scm (pudb): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c607aff3d3..81b99e1d2e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28329,6 +28329,45 @@ development, testing, production]};
 @end itemize")
     (license license:expat)))
 
+(define-public pudb
+  (package
+    (name "pudb")
+    (version "2021.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pudb" version))
+       (sha256
+        (base32 "0p16pvzfa3w02ybg3n0iy5rs23z4rz4a42lb8wh3mcq62y9ik2w7"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'fix-read-only-home
+           (lambda _
+             (setenv "HOME" "/tmp")))
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "pytest")))))))
+    (native-inputs
+     `(("python-numpy" ,python-numpy)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-mock" ,python-pytest-mock)))
+    (propagated-inputs
+     `(("python-jedi" ,python-jedi)
+       ("python-pygments" ,python-pygments)
+       ("python-urwid" ,python-urwid)
+       ("python-urwid-readline" ,python-urwid-readline)))
+    (home-page "https://documen.tician.de/pudb/")
+    (synopsis "Console-based Python debugger")
+    (description
+     "@command{pudb} is a full-screen, console-based Python debugger providing
+all the niceties of modern GUI-based debuggers in a more lightweight and
+keyboard-friendly package.")
+    (license license:expat)))
+
 (define-public python-iwlib
   (package
     (name "python-iwlib")