summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-12-08 00:40:40 +0100
committerLudovic Courtès <ludo@gnu.org>2022-12-08 00:42:58 +0100
commit81191e3410cc00c6438f532599dd0b96d521982f (patch)
tree770ab974bbc00c23e6e4b11516b9f9fb6303e223
parent9ccc94afb266428b7feeba805617d31eb8afb23c (diff)
downloadguix-81191e3410cc00c6438f532599dd0b96d521982f.tar.gz
gnu: guix: Update to 9ccc94a.
This brings the ABI of the 'guix' package in line with the current one,
fixing things built against the 'guix' package such as 'emacs-guix'.

Fixes <https://issues.guix.gnu.org/59864>.
Reported by Amade Nemes Gmail <nemesamade@gmail.com>.

* gnu/packages/package-management.scm (guix): Update to 9ccc94a.
-rw-r--r--gnu/packages/package-management.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index b5b6b3875c..daa83f8d0c 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -165,8 +165,8 @@
   ;; Note: the 'update-guix-package.scm' script expects this definition to
   ;; start precisely like this.
   (let ((version "1.4.0rc1")
-        (commit "020184fd39c6244e0336db3c608d3946b8d20490")
-        (revision 0))
+        (commit "9ccc94afb266428b7feeba805617d31eb8afb23c")
+        (revision 1))
     (package
       (name "guix")
 
@@ -182,7 +182,7 @@
                       (commit commit)))
                 (sha256
                  (base32
-                  "1489fdxdb86shx6bnfs8kihhvw44xqiv6fkx3b67cyw1dakxh1m4"))
+                  "1asx4jqjdp56r9m693ikrzxn4vaga846v2j6956xkavyj19x42nh"))
                 (file-name (string-append "guix-" version "-checkout"))))
       (build-system gnu-build-system)
       (arguments