summary refs log tree commit diff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-09-07 22:49:31 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-30 10:54:01 +0100
commit9eabe0e1fdaa39b562b451404e58fecda9c712fe (patch)
tree1666b68f5d0188b3905f5ded0933f846296ffab1
parent631105947f054a57a10ae01096c60b8849bd8260 (diff)
downloadguix-9eabe0e1fdaa39b562b451404e58fecda9c712fe.tar.gz
gnu: Add emacs-flymake-collection.
* gnu/packages/emacs-xyz.scm (emacs-flymake-collection): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 10eb8427b1..6c33cf362d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1875,6 +1875,44 @@ different tools.  It highlights errors and warnings inline in the buffer, and
 provides an optional IDE-like error list.")
     (license license:gpl3+)))                     ;+GFDLv1.3+ for the manual
 
+(define-public emacs-flymake-collection
+  (package
+    (name "emacs-flymake-collection")
+    (version "1.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mohkale/flymake-collection")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1dxy1bljvd8rar0pivdrfahmgnnjlxm0mlks8mzw3l7k7b7jar6k"))))
+    (build-system emacs-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'chdir
+            (lambda _
+              (chdir "src")))
+          (add-after 'chdir 'move-checkers
+            (lambda _
+              ;; Move checkers to the top level, which is in the
+              ;; EMACSLOADPATH.
+              (for-each (lambda (f)
+                          (rename-file f (basename f)))
+                        (find-files "./checkers" ".*\\.el$")))))))
+    (home-page "https://github.com/mohkale/flymake-collection/")
+    (synopsis "Collection of checkers for Flymake")
+    (description
+     "This package provides a comprehensive list of diagnostic-functions for
+use with Flymake, give users the tools to easily define new syntax checkers
+and help selectively enable or disable diagnostic functions based on major
+modes.")
+    (license license:expat)))
+
 (define-public emacs-flymake-flycheck
   (package
     (name "emacs-flymake-flycheck")