summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-04-08 15:22:47 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-11 11:56:12 +0200
commitca36468083362b5dcad00f144a1cb83123117cbb (patch)
tree104ead90bb06b6cd374c408b459573052d14a57e
parenta18414adc42cb728afda4dfb3ed8d971ce750db3 (diff)
downloadguix-ca36468083362b5dcad00f144a1cb83123117cbb.tar.gz
gnu: Add ocaml-ppx-string.
* gnu/packages/ocaml.scm (ocaml-ppx-string): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/ocaml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8ec5953730..f8f815b358 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6247,6 +6247,29 @@ from type definitions.")
         (list ocaml-base ocaml-typerep ocaml-migrate-parsetree ocaml-ppxlib))
       (license license:asl2.0))))
 
+(define-public ocaml-ppx-string
+  (package
+    (name "ocaml-ppx-string")
+    (version "0.14.1")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/janestreet/ppx_string")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "0a8khmg0y32kyn3q6idwgh0d6d1s6ms1w75gj3dzng0v7y4h6jx4"))))
+    (build-system dune-build-system)
+    (arguments `(#:tests? #f)); no tests
+    (propagated-inputs
+      (list ocaml-base ocaml-ppx-base ocaml-stdio ocaml-ppxlib))
+    (properties `((upstream-name . "ppx_string")))
+    (home-page "https://github.com/janestreet/ppx_string")
+    (synopsis "Ppx extension for string interpolation")
+    (description "This extension provides a syntax for string interpolation.")
+    (license license:expat)))
+
 (define-public ocaml-ppx-base
   (package
     (name "ocaml-ppx-base")