summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:56 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:35 +0200
commitd8a014aac9677cd3d6f3b5b11c706c1ee6f1dd85 (patch)
tree6ecd6de981e61655641d053077c0df50cb964afd
parent5f5d7716be96bc5378d4bd5ad5f58bb8e297da9e (diff)
downloadguix-d8a014aac9677cd3d6f3b5b11c706c1ee6f1dd85.tar.gz
gnu: Add trytond-stock-supply-forecast.
* gnu/packages/tryton.scm (trytond-stock-supply-forecast): New variable.
-rw-r--r--gnu/packages/tryton.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 3bbd3a6311..d1d093f2e4 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4256,3 +4256,27 @@ list on the Product Supplier form.  This allow to restrict the supply week
 days for each supplier on each product.  If no days are defined for a supplier
 a supplying may happens at any day of the week.")
     (license license:gpl3+)))
+
+(define-public trytond-stock-supply-forecast
+  (package
+    (name "trytond-stock-supply-forecast")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_supply_forecast" version))
+       (sha256
+        (base32 "0i5dc9ddd6mfx3zjlcq16isw52b8qy7igaj2lv8jqvkdrc19yfha"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_supply_forecast"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-stock-forecast" ,trytond-stock-forecast)
+       ("trytond-stock-supply" ,trytond-stock-supply)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-stock-supply-forecast")
+    (synopsis "Tryton module to add forecast to supply computation")
+    (description "The @emph{Stock Supply Forecast} Tryton module takes
+forecast into account to compute purchase requests.")
+    (license license:gpl3+)))