summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-16 13:42:45 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-16 15:45:37 +0100
commitddacd13d564b38ac2cb3fee7aa6372790d033b2c (patch)
treea245eb3921cf75c1dbd6aa87574417e284369732
parent16839ec340414a7cf7cff6427e8cf1756efaef8e (diff)
downloadguix-ddacd13d564b38ac2cb3fee7aa6372790d033b2c.tar.gz
gnu: python-zope-testrunner: Update to 5.1.
* gnu/packages/python-web.scm (python-zope-testrunner): Update to 5.1.
[source](uri): Download tarball instead of zipball.
[native-inputs]: Remove UNZIP.  Move PYTHON-ZOPE-INTERFACE and
PYTHON-ZOPE-EXCEPTIONS ...
[propagated-inputs]: ... here.
-rw-r--r--gnu/packages/python-web.scm22
1 files changed, 7 insertions, 15 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 51e246f513..176e54a6ac 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1063,25 +1063,23 @@ forms, HTTP servers, regular expressions, and more.")
 (define-public python-zope-testrunner
   (package
     (name "python-zope-testrunner")
-    (version "4.4.9")
+    (version "5.1")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "zope.testrunner" version ".zip"))
+       (uri (pypi-uri "zope.testrunner" version))
        (sha256
         (base32
-         "1r7iqknhh55y45f64mz5hghgvzx34h1i11k350s0avx6q8gznja1"))))
+         "0w3q66cy4crpj7c0hw0vvvvwf3g931rnvw7wwa20av7yqvv6ajim"))))
     (build-system python-build-system)
     (arguments
      '(#:tests? #f)) ; FIXME: Tests can't find zope.interface.
     (native-inputs
+     `(("python-zope-testing" ,python-zope-testing)))
+    (propagated-inputs
      `(("python-six" ,python-six)
-       ;("python-zope-interface" ,python-zope-interface)
        ("python-zope-exceptions" ,python-zope-exceptions)
-       ("python-zope-testing" ,python-zope-testing)
-       ("unzip" ,unzip)))
-    (propagated-inputs
-     `(("python-zope-interface" ,python-zope-interface)))
+       ("python-zope-interface" ,python-zope-interface)))
     (home-page "https://pypi.org/project/zope.testrunner/")
     (synopsis "Zope testrunner script")
     (description "Zope.testrunner provides a script for running Python
@@ -1089,13 +1087,7 @@ tests.")
     (license license:zpl2.1)))
 
 (define-public python2-zope-testrunner
-  (let ((base (package-with-python2 python-zope-testrunner)))
-    (package
-      (inherit base)
-      (native-inputs
-       (append (package-native-inputs base)
-               `(("python2-subunit" ,python2-subunit)
-                 ("python2-mimeparse" ,python2-mimeparse)))))))
+  (package-with-python2 python-zope-testrunner))
 
 (define-public python-zope-i18nmessageid
   (package