summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-05-16 15:43:23 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-17 01:01:58 +0200
commitf3afef52f6638f5759b5ae94850ed0d9840761c4 (patch)
tree442dbaa8bd7e5b3518ee1162def95f880f6c697d
parent41c77ba3ff56fccee1dc4fc46ae88f0dbe674266 (diff)
downloadguix-f3afef52f6638f5759b5ae94850ed0d9840761c4.tar.gz
gnu: rng-tools: Use INVOKE.
* gnu/packages/linux.scm (rng-tools)[arguments]: Substitute INVOKE for
SYSTEM* and explicitly return #t from phase.
-rw-r--r--gnu/packages/linux.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f949e3fc4d..b357a4b270 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3533,7 +3533,8 @@ The following service daemons are also provided:
        (modify-phases %standard-phases
          (add-after 'unpack 'bootstrap
            (lambda _
-             (zero? (system* "sh" "autogen.sh")))))))
+             (invoke "sh" "autogen.sh")
+             #t)))))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)