summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-10 17:22:41 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-11 15:48:06 -0500
commit14b44398fb61435ae232eaa0f9f3a362eecc0f09 (patch)
tree769b17244c73b827e41448407fdb5e6426fedfa1
parent5bfab17a2bd4dd75a2e833d095a75a28a1fa961f (diff)
downloadguix-14b44398fb61435ae232eaa0f9f3a362eecc0f09.tar.gz
gnu: Add Hash-MultiValue.
* gnu/packages/perl.scm (perl-hash-multivalue): New variable.
-rw-r--r--gnu/packages/perl.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 2d97fe89ef..8421e3c1df 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1002,6 +1002,25 @@ vaguely inspired by John Ousterhout's Tk_ParseArgv.")
                               "Getopt-Tabular-" version))
     (license (package-license perl))))
 
+(define-public perl-hash-multivalue
+  (package
+    (name "perl-hash-multivalue")
+    (version "0.15")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/M/MI/MIYAGAWA/"
+                           "Hash-MultiValue-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1jc37kwpa1fl88va8bd1p95h0vjv1gsvmn7pc2pxj62ga6x0wpc0"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Hash-MultiValue")
+    (synopsis "Store multiple values per key")
+    (description "Hash::MultiValue is an object (and a plain hash reference)
+that may contain multiple values per key, inspired by MultiDict of WebOb.")
+    (license (package-license perl))))
+
 (define-public perl-inc-latest
   (package
     (name "perl-inc-latest")