summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-31 11:02:54 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-31 12:54:46 +0300
commit209a80c109b8ec742cef12c69e1a6a6943b3570e (patch)
tree62e68faaa1ab447735d708deb379bbd7f9f476c4
parenta61e13f7776040e860740bb36c8dda64456e9107 (diff)
downloadguix-209a80c109b8ec742cef12c69e1a6a6943b3570e.tar.gz
gnu: Add julia-queryoperators.
* gnu/packages/julia-xyz.scm (julia-queryoperators): New variable.
-rw-r--r--gnu/packages/julia-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 648dd204f8..0aaa7cd1e0 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1370,6 +1370,30 @@ actual computation.")
 plotting components.")
     (license license:expat)))
 
+(define-public julia-queryoperators
+  (package
+    (name "julia-queryoperators")
+    (version "0.9.3")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/queryverse/QueryOperators.jl")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "06zm4cbn3x49lbpgshhdfvvmgz066qkc8q0d57igm5p8bcp6js22"))))
+    (build-system julia-build-system)
+    (propagated-inputs
+     `(("julia-datastructures" ,julia-datastructures)
+       ("julia-iteratorinterfaceextensions" ,julia-iteratorinterfaceextensions)
+       ("julia-tableshowutils" ,julia-tableshowutils)))
+    (home-page "https://github.com/queryverse/QueryOperators.jl")
+    (synopsis "Query operators for Julia")
+    (description "This package contains the underlying query operators that are
+exposed to users in @code{Query.jl}.")
+    (license license:expat)))
+
 (define-public julia-recipesbase
   (package
     (name "julia-recipesbase")