summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2023-02-28 06:33:42 +0400
committerAndrew Tropin <andrew@trop.in>2023-02-28 06:35:19 +0400
commit2369e8b0ac623aec5508e6eec7246c642787c0d8 (patch)
treedba3e835ff8f536799a0181d73db4b967d1992b0
parenteed41fbcddbbc1f56e6595ba9f471f590ccb96b7 (diff)
downloadguix-2369e8b0ac623aec5508e6eec7246c642787c0d8.tar.gz
gnu: emacs-vertico: Generate info from README.org.
* gnu/packages/emacs-xyz.scm (emacs-vertico)[arguments]: Migrate to gexps,
generate info from README.org.
-rw-r--r--gnu/packages/emacs-xyz.scm30
1 files changed, 20 insertions, 10 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f5a907324c..c585dbe6e5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -34696,16 +34696,26 @@ and preferred services can easily be configured.")
         (base32 "0djc1im6caa67aq0bi8d607ycb1lq4lsirfqsx8kqbfl46852f60"))))
     (build-system emacs-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         ;; Move the extensions source files to the top level, which is
-         ;; included in the EMACSLOADPATH.
-         (add-after 'unpack 'move-source-files
-           (lambda _
-             (let ((el-files (find-files "./extensions" ".*\\.el$")))
-               (for-each (lambda (f)
-                           (rename-file f (basename f)))
-                         el-files)))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; Move the extensions source files to the top level, which is
+          ;; included in the EMACSLOADPATH.
+          (add-after 'unpack 'move-source-files
+            (lambda _
+              (let ((el-files (find-files "./extensions" ".*\\.el$")))
+                (for-each (lambda (f)
+                            (rename-file f (basename f)))
+                          el-files))))
+          (add-after 'install 'makeinfo
+            (lambda* (#:key outputs #:allow-other-keys)
+              (invoke "emacs"
+                      "--batch"
+                      "--eval=(require 'ox-texinfo)"
+                      "--eval=(find-file \"README.org\")"
+                      "--eval=(org-texinfo-export-to-info)")
+              (install-file "vertico.info"
+                            (string-append #$output "/share/info")))))))
     (native-inputs
      (list texinfo))
     (propagated-inputs