summary refs log tree commit diff
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-06-02 22:51:13 +0800
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:00 +0200
commit2b1e7f29535573c6930a8f1ad2b52c7451664e16 (patch)
tree8f106352d8df4fe339efef518178d5ecc9d5bea9
parentf37fd0ca6af1611674e00c31b0cdbed70f58bf9f (diff)
downloadguix-2b1e7f29535573c6930a8f1ad2b52c7451664e16.tar.gz
gnu: libinput: Update to 1.23.0.
* gnu/packages/freedesktop.scm (libinput): Update to 1.23.0.
[native-inputs]: Add python-minimal-wrapper and python-pytest.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/freedesktop.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 9ba53cd044..8a79098ac1 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -590,14 +590,15 @@ freedesktop.org project.")
   ;; Updating this will rebuild over 700 packages through libinput-minimal.
   (package
     (name "libinput")
-    (version "1.19.4")
+    (version "1.23.0")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://freedesktop.org/software/libinput/"
-                                  "libinput-" version ".tar.xz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.freedesktop.org/libinput/libinput.git")
+                    (commit version)))
               (sha256
                (base32
-                "0h5lz54rrl48bhi3vki6s08m6rn2h62rlf08dhgchdm9nmqaaczz"))))
+                "0wnqfnxxvf9jclh64hrb0scn3s1dmwdkmqf7hp0cfmjz5n5nnv7d"))))
     (build-system meson-build-system)
     (arguments
      `(#:configure-flags '("-Ddocumentation=false")
@@ -607,7 +608,7 @@ freedesktop.org project.")
        ;; Meson target anyway.
        #:build-type "release"))
     (native-inputs
-     (list check pkg-config))
+     (list check pkg-config python-minimal-wrapper python-pytest))
     (inputs
      (list cairo
            glib