summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-04-17 19:06:29 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-05-01 15:56:39 +0200
commit2c010c1ba0e7f458623dd61ef99943959bba5874 (patch)
tree7ddfd3481b9d069393a8513fdca6e427ca86f626
parent93d0124a097dbfdd881f8e9729d73e3a7bfeff5f (diff)
downloadguix-2c010c1ba0e7f458623dd61ef99943959bba5874.tar.gz
gnu: emacs-sly-stepper: Adjust to changes in emacs-build-system.
* gnu/packages/emacs-xyz.scm (emacs-sly-stepper)[#:phases]:
<add-contrib-to-emacs-load-path>: Rename to...
<expand-sly-contrib>: ... this.  Use find-files to find contrib directory.
<install>: Find slynk-stepper.lisp in elpa-directory.
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 446a0fd72d..9567d9aa15 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10485,24 +10485,26 @@ inside the source file.")
       (propagated-inputs
        `(("emacs-sly" ,emacs-sly)))
       (arguments
-       '(#:include (cons* "\\.lisp$" "\\.asd$" %default-include)
+       `(#:include (cons* "\\.lisp$" "\\.asd$" %default-include)
          #:phases
          (modify-phases %standard-phases
            ;; The package provides autoloads.
            (delete 'make-autoloads)
            (delete 'enable-autoloads-compilation)
-           (add-after 'add-source-to-load-path 'add-contrib-to-emacs-load-path
+           (add-after 'expand-load-path 'expand-sly-contrib
              (lambda* (#:key inputs #:allow-other-keys)
-               (let ((sly (assoc-ref inputs "emacs-sly")))
+               (let* ((sly (assoc-ref inputs "emacs-sly"))
+                      (contrib (find-files sly "^contrib$" #:directories? #t)))
                  (setenv "EMACSLOADPATH"
-                         (string-append sly "/share/emacs/site-lisp/contrib:"
-                                        (getenv "EMACSLOADPATH"))))
-               #t))
+                         (string-append (string-join contrib ":")
+                                        ":"
+                                        (getenv "EMACSLOADPATH")))
+                 #t)))
            (add-after 'install 'find-agnostic-lizard
              (lambda* (#:key inputs outputs #:allow-other-keys)
                (let* ((out (assoc-ref outputs "out"))
-                      (file (string-append out "/share/emacs/site-lisp/"
-                                           "slynk-stepper.lisp"))
+                      (file (string-append (elpa-directory out)
+                                           "/slynk-stepper.lisp"))
                       (asd (string-append
                             (assoc-ref inputs "cl-agnostic-lizard")
                             "/share/common-lisp/systems/agnostic-lizard.asd")))