summary refs log tree commit diff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 21:04:20 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit327348c629a37e24b83d150dc081af1d74292999 (patch)
tree280fa849b395920f4ae6638e305df22a46e54eb1
parentacd881a49ca1b90fd53754e485961c6b4fdf20d9 (diff)
downloadguix-327348c629a37e24b83d150dc081af1d74292999.tar.gz
gnu: Add ghc-hspec-expectations.
* gnu/packages/haskell.scm (ghc-hspec-expectations): New variable.
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 32a8663b90..0bcf648bb7 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1394,6 +1394,28 @@ lets you set up HTTP connections, transmitting requests and processing the
 responses coming back.")
     (license bsd-3)))
 
+(define-public ghc-hspec-expectations
+  (package
+    (name "ghc-hspec-expectations")
+    (version "0.7.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "http://hackage.haskell.org/package/hspec-expectations/hspec-expectations-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1w56jiqfyl237sr207gh3b0l8sr9layy0mdsgd5wknzb49mif6ip"))))
+    (build-system haskell-build-system)
+    (inputs `(("ghc-hunit" ,ghc-hunit)))
+    (home-page "https://github.com/sol/hspec-expectations")
+    (synopsis "Catchy combinators for HUnit")
+    (description "This library provides catchy combinators for HUnit, see
+@uref{https://github.com/sol/hspec-expectations#readme, the README}.")
+    (license expat)))
+
 (define-public ghc-async
   (package
     (name "ghc-async")