summary refs log tree commit diff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-11-13 11:28:43 +0100
committerRoel Janssen <roel@gnu.org>2020-11-13 14:49:20 +0100
commit3ede804f6d4c38ff0b9a5705544a8c35f6827ff1 (patch)
treedeefaf91fce4e1ebbe9a21b7a0f9db067f9de5e2
parent2646b9d6d36d0d268272f4cd9c52ef710eaf1e19 (diff)
downloadguix-3ede804f6d4c38ff0b9a5705544a8c35f6827ff1.tar.gz
gnu: Add htslib-1.9.
* gnu/packages/bioinformatics.scm (htslib-1.9): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 06972dee51..ba86333fc3 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4250,6 +4250,19 @@ data.  It also provides the @command{bgzip}, @command{htsfile}, and
     ;; the rest is released under the Expat license
     (license (list license:expat license:bsd-3))))
 
+(define-public htslib-1.9
+  (package (inherit htslib)
+    (name "htslib")
+    (version "1.9")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/samtools/htslib/releases/download/"
+                    version "/htslib-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "16ljv43sc3fxmv63w7b2ff8m1s7h89xhazwmbm1bicz8axq8fjz0"))))))
+
 ;; This package should be removed once no packages rely upon it.
 (define htslib-1.3
   (package