summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-24 19:22:52 +0200
committerMarius Bakke <marius@gnu.org>2022-08-27 00:09:03 +0200
commit40c28fa3223c5ec8fedb9e9f1db7eb2153056685 (patch)
tree61b128bbe3d01605febf22f5924dc62b0b68b714
parent1a38540d8d68e0c5c0a57b784eebde233e5ecb23 (diff)
downloadguix-40c28fa3223c5ec8fedb9e9f1db7eb2153056685.tar.gz
gnu: python-cryptography: Update to 37.0.4.
* gnu/packages/python-crypto.scm (python-cryptography-vectors-next): Update to
37.0.4.
(python-cryptography-next): Likewise.
[arguments]: Add phase to adjust pyo3 requirement.  Don't adjust ouroboros
version.
[inputs]: Change from RUST-OUROBOROS-0.14 and RUST-OUROBOROS-MACRO-0.14 to
RUST-OUROBOROS-0.15 and RUST-OUROBOROS-MACRO-0.15.
[native-inputs]: Add PYTHON-PYTEST-BENCHMARK.
-rw-r--r--gnu/packages/python-crypto.scm24
1 files changed, 15 insertions, 9 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 5569f54841..5e78417042 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -441,14 +441,14 @@ is used by the Requests library to verify HTTPS requests.")
 (define-public python-cryptography-vectors-next
   (package
     (name "python-cryptography-vectors")
-    (version "36.0.1")
+    (version "37.0.4")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "cryptography_vectors" version))
        (sha256
         (base32
-         "166mvhhmgglqai1sjkkb76mpdkad2yykam11d2w44hs2snpr117w"))))
+         "1a1yi37ygw0jp72q280cmxd3qn9y9vmcch2bcnjkg2g2202l0qas"))))
     (build-system python-build-system)
     (home-page "https://github.com/pyca/cryptography")
     (synopsis "Test vectors for the cryptography package")
@@ -470,14 +470,14 @@ is used by the Requests library to verify HTTPS requests.")
 (define-public python-cryptography-next
   (package
     (name "python-cryptography")
-    (version "36.0.1")
+    (version "37.0.4")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "cryptography" version))
        (sha256
         (base32
-         "0f1n8bvngarhsssm60xc59xfzkh7yqpyyyypaph3v5bs7pfc3rak"))))
+         "10haq7sn8mrdlhcfs791rczknnxm0wpww0lkpjzcqx141ryc3yb3"))))
     (build-system python-build-system)
     (arguments
      (list
@@ -489,11 +489,13 @@ is used by the Requests library to verify HTTPS requests.")
                   (ice-9 match))
       #:phases
       #~(modify-phases (@ (guix build python-build-system) %standard-phases)
-          (add-after 'unpack 'loosen-ouroboros-version
+          (add-after 'unpack 'adjust-pyo3-requirement
             (lambda _
+              ;; The package depends on 0.15.2, which is not on crates.io(!?).
+              ;; Downgrade to 0.15.1...
               (substitute* "src/rust/Cargo.toml"
-                (("ouroboros = \"0\\.13\"")
-                 "ouroboros = \"0.14\""))))
+                (("pyo3 = \\{ version = \"0\\.15\\.2\"")
+                 "pyo3 = { version = \"0.15.1\""))))
           (add-before 'build 'configure-cargo
             (lambda* (#:key inputs #:allow-other-keys)
               ;; Hide irrelevant inputs from cargo-build-system so it does
@@ -518,6 +520,9 @@ is used by the Requests library to verify HTTPS requests.")
                 (invoke "pytest" "-vv" "tests")))))))
     (inputs
      (list openssl
+           ;; TODO: Most of these inputs are transitive dependencies of
+           ;; the Rust requirements (see src/rust/cargo.toml).  Surely
+           ;; there is a better way than manually listing everything..?
            rust-aliasable-0.1
            rust-asn1-0.8
            rust-asn1-derive-0.8
@@ -538,8 +543,8 @@ is used by the Requests library to verify HTTPS requests.")
            rust-num-integer-0.1
            rust-num-traits-0.2
            rust-once-cell-1
-           rust-ouroboros-0.14
-           rust-ouroboros-macro-0.14
+           rust-ouroboros-0.15
+           rust-ouroboros-macro-0.15
            rust-parking-lot-0.11
            rust-parking-lot-core-0.8
            rust-paste-0.1
@@ -572,6 +577,7 @@ is used by the Requests library to verify HTTPS requests.")
            python-pretend
            python-pytz
            python-pytest
+           python-pytest-benchmark
            python-pytest-subtests
            python-setuptools-rust
            rust