summary refs log tree commit diff
diff options
context:
space:
mode:
authorSughosha <Sughosha@proton.me>2022-12-30 23:17:23 +0000
committerChristopher Baines <mail@cbaines.net>2023-03-01 15:14:36 +0000
commit4a15f2e2263e0bd43ea93bc3d81ce50f565b05cc (patch)
tree3c93eb0c472ee7973da8603d11aa61a2aebd32ee
parentec0f5b5f7eb53486f2c9e313521d497c0e64b004 (diff)
downloadguix-4a15f2e2263e0bd43ea93bc3d81ce50f565b05cc.tar.gz
gnu: Add flat-remix-gtk-theme.
* gnu/packages/gnome-xyz.scm (flat-remix-gtk-theme): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/gnome-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 0457b28bf7..e43b19d69c 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -266,6 +266,33 @@ is mostly flat using a colorful palette with some shadows, highlights, and
 gradients for some depth.")
     (license license:gpl3+)))
 
+(define-public flat-remix-gtk-theme
+  (package
+    (name "flat-remix-gtk-theme")
+    (version "20220627")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/daniruiz/flat-remix-gtk")
+         (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1kwahlrcm9rfsrd97q9lsbfz5390qafwbv78zl6j2vqgqnxhpwng"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f                      ; no included tests
+       #:make-flags `(,(string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:phases (modify-phases %standard-phases
+                  (delete 'configure))))
+    (home-page "https://drasite.com/flat-remix-gtk")
+    (synopsis "GTK application theme with material design")
+    (description "Flat Remix GTK is a GTK application theme inspired by
+material design.  It is mostly flat using a colorful palette with some
+shadows, highlights, and gradients for some depth.")
+    (license license:gpl3+)))
+
 (define-public gnome-plots
   (package
     (name "gnome-plots")