summary refs log tree commit diff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-15 09:38:23 +0100
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-15 10:53:01 +0100
commit584c868fbd6fe5fea5715e2938fc80ec14446502 (patch)
tree7fcb1ce786bcddeca4c90615e9292243ff86e781
parentc3a1373c15908b347cc580abf8522693d21923bb (diff)
downloadguix-584c868fbd6fe5fea5715e2938fc80ec14446502.tar.gz
gnu: Add r-english.
* gnu/packages/cran.scm (r-english): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f5ed504744..b8a57cdb28 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -27487,3 +27487,26 @@ normalization.")
       "This package provides a collection of lexical hash tables, dictionaries,
 and word lists.")
     (license license:gpl3)))
+
+(define-public r-english
+  (package
+    (name "r-english")
+    (version "1.2-5")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "english" version))
+        (sha256
+          (base32
+            "0d6rin40wy2y6k75x8d5qvf03rfy139f309wrl8xwbdb1h8fjkd1"))))
+    (properties `((upstream-name . "english")))
+    (build-system r-build-system)
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page
+      "https://cran.r-project.org/package=english")
+    (synopsis "Translate Integers into English")
+    (description
+      "Allow numbers to be presented in an English language version, one, two,
+three, ...  Ordinals are also available, first, second, third, ...  and
+indefinite article choice, \"a\" or \"an\".")
+    (license license:gpl2)))