summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-10-18 22:40:48 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-24 10:46:12 +0300
commit616b9f7b4d3de76d908d8a75dca623e34477bb63 (patch)
tree7b50a9f7c2ebd34e25ff075cdc3019672dcb2174
parent3f0ff3db2a2c876db7e05dff0fcccd5282fe0beb (diff)
downloadguix-616b9f7b4d3de76d908d8a75dca623e34477bb63.tar.gz
gnu: Remove rust-named-pipe-0.4.
* gnu/packages/crates-io.scm (rust-named-pipe-0.4): Delete variable.
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 0 insertions, 23 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 21126e6b31..8d5f98f9e6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35348,29 +35348,6 @@ statically-sized or dynamically-sized matrices.")
 linear algebra library.")
     (license license:asl2.0)))
 
-(define-public rust-named-pipe-0.4
-  (package
-    (name "rust-named-pipe")
-    (version "0.4.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "named-pipe" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "0azby10wzmsrf66m1bysbil0sjfybnvhsa8py093xz4irqy4975d"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:skip-build? #t     ; Only builds on Windows.
-       #:cargo-inputs (("rust-winapi" ,rust-winapi-0.3))))
-    (home-page "https://github.com/blackbeam/named_pipe")
-    (synopsis "Wrapper for overlapped (asynchronous) IO of Windows's named pipes")
-    (description "This package provides a wrapper for overlapped (asynchronous)
-IO of Windows's named pipes.")
-    (license (list license:expat license:asl2.0))))
-
 (define-public rust-napi-0.5
   (package
     (name "rust-napi")