summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 23:46:33 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:37 -0400
commitbec1c898917d571cc099bda20472bac4377fb22a (patch)
tree2c6ba3eadccb8000a7c3385f1c7b91cc148cd3f2
parentc75c1e811e6e602f30bdd2da1e32e93cedb074e7 (diff)
downloadguix-bec1c898917d571cc099bda20472bac4377fb22a.tar.gz
gnu: Remove python2-mccabe.
* gnu/packages/python-xyz.scm (python2-mccabe): Delete variable.
-rw-r--r--gnu/packages/python-xyz.scm3
-rw-r--r--guix/lint.scm20
2 files changed, 10 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9b6d3eb569..76fe4d6158 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10706,9 +10706,6 @@ file (e.g. @file{PKG-INFO}).")
 cyclomatic complexity of Python source code.")
     (license license:expat)))
 
-(define-public python2-mccabe
-  (package-with-python2 python-mccabe))
-
 (define-public python-flake8
   (package
     (name "python-flake8")
diff --git a/guix/lint.scm b/guix/lint.scm
index 375f189335..aa16efe6db 100644
--- a/guix/lint.scm
+++ b/guix/lint.scm
@@ -494,16 +494,16 @@ of a package, and INPUT-NAMES, a list of package specifications such as
             "m4"
             "qttools"
             "yasm" "nasm" "fasm"
-            "python-coverage" "python2-coverage"
-            "python-cython" "python2-cython"
-            "python-docutils" "python2-docutils"
-            "python-mock" "python2-mock"
-            "python-nose" "python2-nose"
-            "python-pbr" "python2-pbr"
-            "python-pytest" "python2-pytest"
-            "python-pytest-cov" "python2-pytest-cov"
-            "python-setuptools-scm" "python2-setuptools-scm"
-            "python-sphinx" "python2-sphinx"
+            "python-coverage"
+            "python-cython"
+            "python-docutils"
+            "python-mock"
+            "python-nose"
+            "python-pbr"
+            "python-pytest"
+            "python-pytest-cov"
+            "python-setuptools-scm"
+            "python-sphinx"
             "scdoc"
             "swig"
             "qmake"