summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-10 21:38:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-11 01:03:20 +0100
commitc35364ea0331280e412719518e9c27e9940bedba (patch)
tree140470559183aacfceb5c643e3724b42b682cce8
parenteb21f330b9f217d8be430e657b10732aceebef99 (diff)
downloadguix-c35364ea0331280e412719518e9c27e9940bedba.tar.gz
gnu: Add r-highlight.
* gnu/packages/cran.scm (r-highlight): New variable.
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 20ed1e40fb..fa991063e2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -26559,3 +26559,25 @@ unit tests of graphics).")
 to add graphical unit tests.  It provides a Shiny application to manage the
 test cases.")
     (license license:gpl3)))
+
+(define-public r-highlight
+  (package
+    (name "r-highlight")
+    (version "0.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "highlight" version))
+       (sha256
+        (base32
+         "1shar4y07wyixg0ichdrn2xhgwkl3mv2pxkalqzisc69w605b3hf"))))
+    (properties `((upstream-name . "highlight")))
+    (build-system r-build-system)
+    (home-page "https://github.com/hadley/highlight")
+    (synopsis "Syntax highlighter for R code")
+    (description
+     "This package provides a syntax highlighter for R code based on the
+results of the R parser.  It supports rendering in HTML and LaTeX markup.  It
+includes a custom Sweave driver performing syntax highlighting of R code
+chunks.")
+    (license license:gpl3+)))