summary refs log tree commit diff
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2022-07-05 08:39:43 +0200
committerLudovic Courtès <ludo@gnu.org>2022-07-10 23:57:15 +0200
commitc9fad6a2ad8c530ba5a5a78f6e9349a038e8ae88 (patch)
tree1ce66a9514a0d3de6fe197a1477a0c1d204b6ba9
parentd301374d97fc3b658afef3dd399ee71690eed572 (diff)
downloadguix-c9fad6a2ad8c530ba5a5a78f6e9349a038e8ae88.tar.gz
gnu: Add texlive-babel-dutch.
* gnu/packages/tex.scm (texlive-babel-dutch): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 08e506bf1c..47e015da71 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10982,6 +10982,32 @@ mechanism.  Line numbering may be extended to footnote lines, using the
 fnlineno package.")
     (license license:lppl1.3a+)))
 
+(define-public texlive-babel-dutch
+  (let ((template (simple-texlive-package
+                   "texlive-babel-dutch"
+                   (list "/source/generic/babel-dutch/")
+                   (base32
+                    "1a40rz6rznawgarnhk0wh751sln2x9js4420i0758y2clf4rlhg9"))))
+    (package
+      (inherit template)
+      (arguments
+       (substitute-keyword-arguments (package-arguments template)
+         ((#:tex-directory _ '())
+          "generic/babel-dutch")
+         ((#:build-targets _ '())
+          ''("dutch.ins")) ; TODO: use dtx and build documentation
+         ((#:phases phases) `(modify-phases ,phases
+                               (add-after 'unpack 'chdir
+                                 (lambda _
+                                   (chdir "source/generic/babel-dutch")))))))
+      (home-page "https://www.ctan.org/pkg/babel-dutch")
+      (synopsis "Babel support for Dutch")
+      (description
+       "This package provides the language definition file for support of Dutch
+in @code{babel}.  It provides all the necessary macros, definitions and
+settings to typeset Dutch documents.")
+      (license license:lppl1.3c+))))
+
 (define-public texlive-babel-finnish
   (let ((template (simple-texlive-package
                    "texlive-babel-finnish"