summary refs log tree commit diff
diff options
context:
space:
mode:
authorEmmanuel Beffara <manu@beffara.org>2023-07-20 16:51:25 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-07-20 16:59:49 -0400
commitcb526989d14bdeb2fe31d1286cf53e606243bb1e (patch)
treeb4f9f266a2e2a975a89ef1fd9756f3917fe87b64
parentcf820ca687fe28bc69f2c15184d6a75b4d777c18 (diff)
downloadguix-cb526989d14bdeb2fe31d1286cf53e606243bb1e.tar.gz
gnu: cups-filters: Add coreutils and sed to wrapped PATH.
* gnu/packages/cups.scm (cups-filters) [arguments]: Add coreutils and sed to
PATH in wrap-filters phase.
[inputs]: Add coreutils and sed.

Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/cups.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 5791d4994a..a707006c3b 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -201,9 +201,11 @@ driver is known to work with these printers:
                       (wrap-program file
                         `("PATH" ":" prefix
                           (,(string-append
+                             #$(this-package-input "coreutils") "/bin:"
                              #$(this-package-input "ghostscript-with-cups")
                              "/bin:"
-                             #$(this-package-input "grep") "/bin")))))
+                             #$(this-package-input "grep") "/bin:"
+                             #$(this-package-input "sed") "/bin")))))
                     (find-files (string-append #$output
                                                "/lib/cups/filter"))))))))
     (native-inputs
@@ -211,6 +213,7 @@ driver is known to work with these printers:
            pkg-config))
     (inputs
      (list avahi
+           coreutils
            fontconfig
            freetype
            font-dejavu                  ; also needed by test suite
@@ -225,6 +228,7 @@ driver is known to work with these printers:
            glib
            qpdf
            poppler
+           sed
            cups-minimal))
     (home-page "https://wiki.linuxfoundation.org/openprinting/cups-filters")
     (synopsis "OpenPrinting CUPS filters and backends")