summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-09-12 09:55:39 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-09-12 11:18:57 +0200
commite44dd9a4e14c8009f8440b26bf4125a62e902767 (patch)
tree88fcfbc6112857aa3e3999ce24160d01ee27378c
parent466bf553d7b405b8c227b8a99aa6ef8b7a4392a8 (diff)
downloadguix-e44dd9a4e14c8009f8440b26bf4125a62e902767.tar.gz
gnu: sbcl-osicat: Fix build.
* gnu/packages/lisp-xyz.scm (sbcl-osicat)[arguments]: Remove custom 'cleanup'
  phase.
-rw-r--r--gnu/packages/lisp-xyz.scm16
1 files changed, 0 insertions, 16 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b6d1d6e612..081aef65e0 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -9035,22 +9035,6 @@ MOP easier to use.")
          (sha256
           (base32 "15viw5pi5sa7qq9b4n2rr3dj2jkqr180rh9z1lh8w3rgl42i2adc"))))
       (build-system asdf-build-system/sbcl)
-      (arguments
-       `(#:phases
-         (modify-phases %standard-phases
-           ;; The cleanup phase moves files around but we need to keep the
-           ;; directory structure for the grovel-generated library.
-           (replace 'cleanup
-             (lambda* (#:key outputs #:allow-other-keys)
-               (let* ((out (assoc-ref outputs "out"))
-                      (lib (string-append out "/lib/sbcl/")))
-                 (delete-file-recursively (string-append lib "src"))
-                 (delete-file-recursively (string-append lib "tests"))
-                 (for-each delete-file
-                           (filter (lambda (file)
-                                     (not (member (basename file) '("libosicat.so"))))
-                                   (find-files (string-append lib "posix") ".*"))))
-               #t)))))
       (inputs
        `(("alexandria" ,sbcl-alexandria)
          ("cffi" ,sbcl-cffi)