summary refs log tree commit diff
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-11-29 07:00:24 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2022-11-27 01:00:02 +0100
commite72313959bb2a709647c44b9697aa69f300fc8a4 (patch)
tree2c10df902d06ff11b7218561df9fb5cc43a46ac3
parent3e697f3642946b760541864d7a07ea1459378b53 (diff)
downloadguix-e72313959bb2a709647c44b9697aa69f300fc8a4.tar.gz
gnu: Add rust-rstest-macros-0.14.
* gnu/packages/crates-io.scm (rust-rstest-0.14): New variable.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/crates-io.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e57e68a156..1b659e3e4a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -46824,6 +46824,33 @@ table-based tests.")
 table-based tests.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-rstest-macros-0.14
+  (package
+    (name "rust-rstest-macros")
+    (version "0.14.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "rstest-macros" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0rlwp3r1dg3fl4f100wjd3ya7dhs23vpyqgf7vg5mac50s5fc5ah"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list #:skip-build? #t
+           #:cargo-inputs
+           `(("rust-cfg-if" ,rust-cfg-if-1)
+             ("rust-proc-macro2" ,rust-proc-macro2-1)
+             ("rust-quote" ,rust-quote-1)
+             ("rust-rustc-version" ,rust-rustc-version-0.4)
+             ("rust-syn" ,rust-syn-1))))
+    (home-page "https://github.com/la10736/rstest")
+    (synopsis "Procedural macros for @code{rstest}.")
+    (description
+     "This package provides the procedural macro crate for
+@code{rstest}.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-rug-1
   (package
     (name "rust-rug")