summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-12 20:55:23 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-12 20:55:23 +0300
commitf85dacd8697e89e68b346c34905d7a7f40bf66ff (patch)
treef584d85afe181411593679821c1159545b447a2f
parenta1eca979fb8da842e73c42f4f53be29b169810f2 (diff)
downloadguix-f85dacd8697e89e68b346c34905d7a7f40bf66ff.tar.gz
gnu: go-1.17: Don't build with gccgo.
* gnu/packages/golang.scm (go-1.17)[native-inputs]: When building on
architectures not supported by go-1.4 use go-1.16 in place of gccgo.
-rw-r--r--gnu/packages/golang.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index bd9c239b39..5786da586c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -793,7 +793,13 @@ in the style of communicating sequential processes (@dfn{CSP}).")
                   (install-file file (string-append out "/share/doc/go")))
                 '("AUTHORS" "CONTRIBUTORS" "CONTRIBUTING.md" "PATENTS"
                   "README.md" "SECURITY.md"))))))))
-    (inputs (alist-delete "gcc:lib" (package-inputs go-1.16)))))
+    (inputs (alist-delete "gcc:lib" (package-inputs go-1.16)))
+    (native-inputs
+     `(,@(if (not (member (%current-system) (package-supported-systems go-1.4)))
+           ;; gccgo-10.4, 11.3 and lower has a bug which causes bootstrapping
+           ;; to fail. Use go-1.16 until we have a newer version available.
+           (alist-replace "go" (list go-1.16) (package-native-inputs go-1.16))
+           (package-native-inputs go-1.16))))))
 
 (define-public go go-1.14)