summary refs log tree commit diff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-05-13 22:27:57 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-05-27 14:58:29 +0200
commit00d8a4116427fb69f79e334bfbf91920a0d871d2 (patch)
tree85ec404853963c88562f955c39b134671ebee1de
parentb90738f02c33b23d811a5a2f55f77ccc89928af8 (diff)
downloadguix-00d8a4116427fb69f79e334bfbf91920a0d871d2.tar.gz
gnu: gtksourceview: Fix build.
* gnu/packages/gtk.scm (gtksourceview)[#:phases]<pre-check>: Set “GDK_BACKEND”
and “GTK_A11Y”.
-rw-r--r--gnu/packages/gtk.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index de45eb3870..b957989689 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -616,6 +616,11 @@ printing and other features typical of a source code editor.")
                ;; Tests require a running X server.
                (system (string-append Xvfb " :1 &"))
                (setenv "DISPLAY" ":1")
+               ;; Use an X11 setup to find the display.
+               (setenv "GDK_BACKEND" "x11")
+               ;; Avoid spawning (and failing to connect to) the accessiblity
+               ;; bus.
+               (setenv "GTK_A11Y" "none")
                ;; For the missing /etc/machine-id.
                (setenv "DBUS_FATAL_WARNINGS" "0")))))))
     (native-inputs