summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-23 15:53:36 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-23 15:55:55 +0100
commit016fd7720db06f0945e345cc9d5043642f3b8720 (patch)
tree99281cb5f8759babc858da254402c9b6f505c8f5
parenta67218efeea1ed9c5f793a061f0c6602bb11d674 (diff)
downloadguix-016fd7720db06f0945e345cc9d5043642f3b8720.tar.gz
gnu: Add specification-ipld.
* gnu/packages/specifications.scm (specification-ipld): New variable.

Change-Id: Ib36d0cdb4a6d20da789ba20830945c8a7d223b69
-rw-r--r--gnu/packages/specifications.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/specifications.scm b/gnu/packages/specifications.scm
index 125d794932..4e6c7b81ff 100644
--- a/gnu/packages/specifications.scm
+++ b/gnu/packages/specifications.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -25,6 +26,36 @@
   #:use-module (guix packages)
   #:use-module (guix build-system copy))
 
+(define-public specification-ipld
+  (let ((commit "84a5cc6c168314a26be0d447c26fe76e46ce2a42")
+        (revision "0"))
+    (package
+      (name "specification-ipld")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/ipld/ipld")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0avgjp4hjkh4jmsxx09vnwi74rax6409k28h29jwfl95v42h6yyl"))))
+      (build-system copy-build-system)
+      (arguments
+       '(#:install-plan '(("./specs/schemas" "share/ipld/specs/"))
+         #:phases (modify-phases %standard-phases
+                    (delete 'strip))))
+      (home-page "https://ipld.io/")
+      (synopsis "InterPlanetary Linked Data")
+      (description
+       "This package provides specification schemas of
+@acronym{InterPlanetary Linked Data, IPLD} which may be used for the test
+suites of application implementing the standard.")
+      ;; This library is dual-licensed under either of Apache 2.0 or MIT
+      ;; terms.
+      (license (list license:expat license:asl2.0)))))
+
 (define-public specification-multibase
   (let ((commit "4c8344e37852773de155f587dcf5897771b3fc19")
         (revision "1"))