summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2017-03-11 22:14:22 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-03-12 10:28:07 +1000
commit02eec38ee16acc1bf933ac28e989501a73a1a3a1 (patch)
tree308edb608bf9ad2a39fffaca248d1d8f5e83e0d2
parentd1906e3147966e780d2f52d3ccebb85a80ad49e5 (diff)
downloadguix-02eec38ee16acc1bf933ac28e989501a73a1a3a1.tar.gz
gnu: Add r-ranger.
* gnu/packages/statistics.scm (r-ranger): New variable.

Signed-off-by: Ben Woodcroft <donttrustben@gmail.com>
-rw-r--r--gnu/packages/statistics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index c48c2be6ac..401cb17e69 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4796,3 +4796,26 @@ multivariate case.")
 algorithms (@code{tclust}) based on trimming and including some graphical
 diagnostic tools (@code{ctlcurves} and @code{DiscrFact}).")
     (license license:gpl3)))
+
+(define-public r-ranger
+  (package
+    (name "r-ranger")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ranger" version))
+       (sha256
+        (base32
+         "1fwqwbi0dnla16x6zj14rf95qr5gmilfmlrwnv7s960h4yiw4n97"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-rcpp" ,r-rcpp)))
+    (home-page "https://github.com/imbs-hl/ranger")
+    (synopsis "Fast implementation of random forests")
+    (description
+     "This package provides a fast implementation of Random Forests,
+particularly suited for high dimensional data.  Ensembles of classification,
+regression, survival and probability prediction trees are supported.  Data from
+genome-wide association studies can be analyzed efficiently.")
+    (license license:gpl3)))