summary refs log tree commit diff
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2022-11-13 14:39:02 +0800
committerChristopher Baines <mail@cbaines.net>2022-11-19 13:35:50 +0000
commit04b5450ad852735dfa50961d3afc789b2e52b407 (patch)
treeaba8d525fb3f253ee63c7d22a9ca7e3d4ae1acc7
parentfc7c8fe063a834722a38ea73952d6ee5e32203bf (diff)
downloadguix-04b5450ad852735dfa50961d3afc789b2e52b407.tar.gz
gnu: Add rofi-wayland.
* gnu/packages/xdisorg.scm (rofi-wayland): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/xdisorg.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 2012fcbdf8..298e6f3e47 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1873,6 +1873,30 @@ applications you regularly use and also allows you to search for an application
 by name.")
     (license license:expat)))
 
+(define-public rofi-wayland
+  (let ((base rofi))
+    (package
+      (inherit rofi)
+      (name "rofi-wayland")
+      (version "1.7.5+wayland1")
+      (source (origin
+                (method url-fetch)
+                (uri (string-append "https://github.com/lbonn/rofi"
+                                    "/releases/download/" version
+                                    "/rofi-" version ".tar.xz"))
+                (sha256
+                 (base32
+                  "09n71wv3nxpzpjmvqmxlxk0zfln3x2l8admfq571781p9hw0w6wp"))))
+      (build-system meson-build-system)
+      (inputs
+       (modify-inputs (package-inputs base)
+         (append wayland wayland-protocols)))
+      (description
+       (string-append
+        (package-description base)
+        "  This package, @code{rofi-wayland}, provides additional wayland
+support.")))))
+
 (define-public rofi-calc
   (package
     (name "rofi-calc")